World of Warcraft Launch Day Woes

After so many years of World of Warcraft, you would think Blizzard would know how to launch a game flawlessly… you’d be dead wrong.

The first interesting choice Blizzard made was in the selection of doing a pre-order bonus – A way to automatically level a character to level 90 (a new one or an already existing character.  What they failed to do was offer a way for people to physically order WoW and get that same bonus early.  For people that ordered the expansion online, they received the bonuses immediately (Mount, Pet, and the 90 boost).  For people like me, who ordered the Collector’s Edition, I didn’t receive anything until launch day.  I couldn’t even pick the game up at midnight since my Gamestop didn’t have enough pre-orders.  When I asked the Gamestop Manager why this was, he speculated it was due to the online orders of people who wanted the bonuses before the expansion released.

If you were lucky (or unlucky) enough to have the game at 3AM EST, you were able to log in and start exploring the new zones.  However, 2 crippling bugs became apparent and got worse as the day went on.  The first was a bug with a very early opening quest.  You have to interact with an Architect’s scope to build your Garrison and apparently that bugged out, essentially preventing anyone from getting past the quest.  Blizzard quickly hotfixed the quest and by the time I logged on at 10:30AM , the problem had gone away.  The new issue was the Gormaul Tower Quest.  The quest relies  on the Blizzard technology of Phasing (Phasing allows for live changing of the actual environment per player based on quest status or time).  When you would phase into the area, all of the enemies would also disappear.  After awhile, a lot of people were trying to get the quest done and essentially causing the server to become crippled due to the thousands of players that were getting stuck in the zone, unable to continue leveling and just grinding on enemies or exploring.  So even when they hotfixed the issue hours later, the area was still laggy, almost to the point of being unplayable.

While all of that was going on, a new fun bug came up.  Since the Garrisons effectively are on their own server, when that server goes down, the entire area becomes locked out.  So when I got on a flight path to fly somewhere, as I flew over my Garrison the mount just stopped in mid-air.  I was unable to do literally anything.  I relogged, reloaded the UI, when I tried to exit in game it wouldn’t let me so I had to ALT-F4, I couldn’t even queue for a dungeon.  Here’s a fun little clip of the issue:

I’ve been playing WoW since it released and I have played my fair share of other MMOs over the years.  This may be the worst launch of an MMO I have ever seen.  It’s surprising since Blizzard has had years of experience with just this type of launch and are having so many issues.

 

I just hope after the maintenance today, everything goes back to working correctly.  I need to get to 100!